注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

风之云的足迹

点击这里添加博客描述

 
 
 

日志

 
 

Windows下使用最新的JDK1.7.0_51以上版本连接Jenkins出现SecurityException安全异常  

2014-01-28 14:41:53|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
如果你安装了最新的JDK7,具体版本是1.7.0_u51以上版本,然后连接Jenkins平台出现了一些安全性限制或者类似以下的一些错误提示:

java.lang.SecurityException: Missing required Permissions manifest attribute in main jar: http://*****:**/jnlpJars/remoting.jar

at com.sun.deploy.security.DeployManifestChecker.verifyMainJar(Unknown Source)

at com.sun.deploy.security.DeployManifestChecker.verifyMainJar(Unknown Source)

at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)

at com.sun.javaws.Launcher.run(Unknown Source)

at java.lang.Thread.run(Unknown Source



这个是由于最新版本的 Java 7 Update51版本升级中加入了下面的安全性的机制导致的
Improved security settings in the Java 7 client prohibit you from launching the Java application.


出现这个问题不要怕,我们可以尝试通过以下方式进行修复:

1、进入Windows控制面板,点击”程序“-”Java“

Windows下使用最新的JDK1.7.0_51以上版本连接Jenkins出现SecurityException安全异常 - 孔庆云kevin - 风之云的足迹

2、点击Java控制面板的“安全”标签,然后点击“编辑站点列表”

Windows下使用最新的JDK1.7.0_51以上版本连接Jenkins出现SecurityException安全异常 - 孔庆云kevin - 风之云的足迹

3、点击"添加",然后在"位置"处输入提示的IP地址和端口号即可,这里的地址输入连接出错时候提示你的那个地址即可

Windows下使用最新的JDK1.7.0_51以上版本连接Jenkins出现SecurityException安全异常 - 孔庆云kevin - 风之云的足迹

4、接下去就是一路继续、确定到完成

  评论这张
 
阅读(1304)| 评论(1)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018