注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

风之云的足迹

点击这里添加博客描述

 
 
 

日志

 
 

windows下安装多个Ruby版本  

2010-12-02 23:55:14|  分类: Rails |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
因为两个项目使用的Ruby版本不一样,所以需要在电脑上安装多个Ruby版本,记录下安装过程中出现的一些问题。
1. 【问题描述】原来安装的是Ruby1.8.7,现在又安装了一个Ruby1.8.6版本,在NetBeans中指定了该项目使用的Ruby版本是1.8.6,但是运行时候提示gem版本太低是0.9.4,需要升级。但是通过gem -v查看版本已经是1.3.7,这个应该是Ruby1.8.7中带的gem版本,所以这时候使用gem update –system命令会提示没有需要更新的。
【解决方法】 修改电脑环境变量path的值,暂时先去除1.8.7的配置,删除后再次查看ruby -v出现版本是1.8.6了,如果没有出现重启下电脑试试

2. 【问题描述】既然Ruby的版本已经是1.8.6了,查看gem的版本也是0.9.4,这时候应该可以升级了,但是运行gem update –system出现
ERROR:  While executing gem ... (Gem::RemoteSourceException)
    HTTP Response 302
的错误
【解决方法】还是gem版本太低的问题,手动下载gem升级文件http://rubyforge.org/frs/download.php/70695/rubygems-update-1.3.7.gem
下载后放在ruby1.8.6的根目录,然后进入到根目录执行gem install --local rubygems-update-1.3.7.gem
出现提示Could not find main page README,查看gem -v还是0.9.4版本
需要再次执行update_rubygems命令,再次查看gem版本,正确升级到1.3.7
  评论这张
 
阅读(1069)| 评论(3)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018